top of page

GRE

Tunneling provides a mechanism to transport packets of one protocol within another protocol. The protocol that is carried is called as the passenger protocol, and the protocol that is used for carrying the passenger protocol is called as the transport protocol. Generic Routing Encapsulation (GRE) is one of the available tunneling mechanisms which uses IP as the transport protocol and can be used for carrying many different passenger protocols. The tunnels behave as virtual point-to-point links that have two endpoints identified by the tunnel source and tunnel destination addresses at each endpoint.

3.PNG

1. Create Tunnel interface on R1 and enable routing.


int tunnel 1

ip address 192.168.1.1 255.255.255.0

tunnel source fa 0/0

tunnel destination 192.1.20.3

!
router eigrp 10

net 192.168.1.0

net 10.11.11.0

int lo 0

ip add 10.11.11.11 255.255.255.0

2.Similar configuration has to be done on R3

int tunnel 1

ip address 192.168.1.3 255.255.255.0

tunnel source fa 0/1

tunnel destination 192.1.10.1


!

router eigrp 10

net 192.168.1.0

net 10.22.22.0

 

int lo 0

ip add 10.22.22.22 255.255.255.0

We can see the neighborship being established between two interfaces using EIGRP

10.PNG

But why are we seeing 10.0.0.0/8 , why not 10.11.11.11 . This is because we are using default feature of EIGRP , which summarizes the routes to its classful boundaries.

11.PNG

Lets change it!

12.PNG
13.PNG

By default tunnel has GRE protocol enabled on the interface which can be seen below. The source and destination are the public IP addresses.

14.PNG

Below is the packet capture that was taken to show how packets are encapsulated but not encrypted.

16.PNG
bottom of page